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UNIT 2 – SPREADSHEET TOOLS 

 Introduction to Spreadsheet:  

 A spreadsheet is a large sheet of paper with columns and rows that organizes data about 

transactions for a business person to examine.  

 It spreads or shows all of the costs, income, taxes, and other related data on a single 

sheet of paper for a manager to examine when making a decision.  

 OR A spreadsheet is a computer application that simulates a paper accounting 

worksheet. It displays multiple cells usually in a two-dimensional matrix or grid 

consisting of rows and columns.  

 Each cell contains alphanumeric text, numeric values or formulas.  

 A formula defines how the content of that cell is to be calculated from the contents of 

any other cell (or combination of cells) each time any cell is updated.  

 Spreadsheets are frequently used for financial information because of their ability to re-

calculate the entire sheet automatically after a change to a single cell is made.  

 The spreadsheet program summarizes information from many paper sources in one place 

and presents the information in a format to help a decision maker see the financial big 

picture for the company.  

Examples of some popular spread sheet packages:  

1. VisiCalc. 

2. Lotus 1-2-3. 

3. Microsoft Excel. 

4. Numbers (Apple). 

5. CaIc (Open Office)  

Applications of a Spreadsheet 

 Budgets 

 Annual reports of business firms  

 Income statement and income tax calculations  

  Payrolls  

  Invoicing (Billing)  

  Accounts payable and receivable  

 Production and marketing analysis  

 Investment and loan analysis  

 Banking and other financial services  
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 Inventory control  

  Tender evaluation  

  Scientific calculation  

  Cost-effective analysis  

Features of an Excel/Spreadsheet: 

Some of the important features of Excel / spreadsheet are:  

1. Automatic recalculation: Recalculates the result of a mathematical formula automatically 

if the source data changes.  

2. Fast and accurate results: Spreadsheets are fast and accurate tools for performing 

complex data analysis.  

3 Windows-based application Ms Excel has an interface similar to Windows NT Like all  

Windows applications, Excel has toolbars, shortcut menus, Autocorrect Online help and  

Wizards This makes Excel easier to learn for users of windows  

4. Workbooks: Workbooks are containers that hold one or more worksheets. Keeping all 

sheets  

that are related to a project in one file reduces the need to maintain different files  

5. Auditing: Worksheet auditing is a feature that checks, a worksheet for errors. Auditing 

can be  

used to relate formulas in different cells and locate the source of a calculation error  

6. OLE support Excel worksheets can contain any object, like a document, a picture or a 

video  

clip This feature is known as Object Linking and Embedding (OLE) This capability can be 

used  

to integrate Excel with all other applications  

7 Data entry forms You can create custom data entry forms within a worksheet Validation 

rules  

and formatting can be included within a form  

8 Large data management capacity Excel can maintain large volumes of data at a time A  

worksheet can contain 65 536 rows and 256 columns A single cell can contain a maximum 

of  255 characters. One, workbook can contain a maximum of 255 worksheets. Such data  

management capabilities make Excel a powerful spreadsheet application  

9 Data analysis features Excel contains powerful tools that in data analysis Pivot tables  

Microsoft Query and Data Map tools allow users to present data in different ways to 

facilitate  

analysis.  

10 Decision making: easily and quickly produce reports and get answer to “ what-if” 

questions  
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11. Macros: Excel allows you to define macros, which you can use to combine a series of  

actions to automate your work.  

12. Charts: Charts present data visually, more effectively and help to analyze data.  

The Microsoft Excel Window 

 

The Microsoft Excel Window  
Microsoft Excel is an electronic spreadsheet. You can use it to organize your data into rows 

and  

columns. You can also use it to perform mathematical calculations quickly. Starting 

Microsoft  

Excel 2007, the following window appears and the screen looks similar to the one shown 

here. 

 

Worksheets 

 
Microsoft Excel consists of worksheets. Each worksheet contains columns and rows. The 

columns are lettered A to Z and then continuing with AA, AB, AC and so on; the rows are 

numbered 1 to 1,048,576. The number of columns and rows you can have in a worksheet is 

limited by your computer memory and your system resources.  

The combination of a column coordinate and a row coordinate make up a cell address. For 

example, the cell located in the upper-left corner of the worksheet is cell Al, meaning 

column A, row 1.  

 

 

The Status Bar  
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The Status bar appears at the very bottom of the Excel window and provides such 

information as the sum, average, minimum, and maximum value of selected numbers. You 

can change what displays on the Status bar by right-clicking on the Status bar and selecting 

the options you want from the Customize Status Bar menu. You click a menu item to select 

it. You click it again to deselect it. A check mark next to an item means the item is selected. 

Organization of an Excel Worksheet  

1. Rows and Columns: A worksheet is made up of rows and columns. The worksheet 

contains  

256 columns and 65536 rows. The Excel worksheet is more than 7 meters wide and 100 

meters  

long.  

2. Cell and Cell Address: The area formed by intersection of row and column is called a 

cell.  

The cell is the smallest unit in the worksheet that is used to store the data. The cell formed 

by  

intersection of row and column is called a cell address. E.g. Al.  

3. Active cell: A thick border around one cell is known as active cell. OR The cell(s) that is  

selected is known as active cell. 

What is a range?  

A range is a rectangular area in the worksheet. A range may include just a single cell, a 
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number of consecutive cells in a row or column, or cells from consecutive rows and 

columns. A range may include cell from multiple rows and columns however it must form 

a rectangle in order to be valid. One can also specify a range by pointing also. Excel is 

displaying „Point‟ as the mode indicator, indicating that a range is being selected by the 

pointing method. 

Workbook:  

Workbook is a collection of one or more than one worksheets.  

Sample workbooks:  

Expense statement  

Invoice  

Purchase order  

Business planner 

steps to create a sample workbook:  

1 Select New option from the file menu  

2 Select the spreadsheet solutions tab in the dialog box  

3. Select a sample application and click on OK button.  

 

Workspace: Saves the current opened workbooks and their size and position on the screen. 

The default name of workspace is Resume and extension is .XLW.  

 

Formula bar: Formula bar is located near the top of the window that displays the constant 

value or formula used in the active cell. Formula bar can be used to enter data in cell. It 

consist of Cell Reference area or Name box, Cancel current entry button, Enter current entry 

button, Function builder and Text box.  

 
 

If you do not see the Formula bar in your window, perform the following steps:  

1. Choose the View tab.  

2. Click Formula Bar n the Show/Hide group. The Formula bar appears. 

Cell Reference area or Name box: The box at the left end of the formula bar that identifies 

the selected cell, chart item, or drawing object. Type the name in the Name box, and then 

press Enter to quickly name a selected cell or range. To move to and select a previously 
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named cell, click its name in the name box.  

Cancel Current Entry: Cancels the formula entry, closes the formula palette, and returns you 

to the active cell.  

Enter value: Enter the formula displayed in the formula bar into the active cell in your 

worksheet. The cell references, values, and expected result of the formula you enter are 

displayed in the formula palette.  

Function builder: Displays the formula palette to assist you in building a formula with 

worksheet functions.  

 

Different ways to navigate the worksheet:  

By using the arrow keys, you can move around your worksheet. You can use the down 

arrow key to move downward one cell at a time. You can use the up arrow key to move 

upward one cell at a time. You can use the Tab key to move across the page to the right, one 

cell at a time. You can hold down the Shift key and then press the Tab key to move to the 

left, one cell at a time. You can use the right and left arrow keys to move right or left one 

cell at a time. The Page Up and Page Down keys move up and down one page at a time. If 

you hold down the Ctrl key and then press the Home key, you move to the beginning of the 

worksheet.  

 

Move Around the Worksheet  

Depending on the position of the mouse, the mouse pointer can have one of three shapes. 

When it is inside the cell, its shape is like a plus sign +  When it is on the border except the 

bottom right corner, its shape is like a pointed arrows . And, when the mouse pointer is on 

the bottom right corner of the border, its shape changes to a small plus + sign.  

The down Arrow Key  

• Press the down arrow key several times. Note that the cursor moves downward one cell at 

a time.  

The Up Arrow Key  
• Press the up arrow key several times. Note that the cursor moves upward one cell at a 

time.  

The Tab Key  

1. Move to cell Al.  

2. Press the Tab key several times. Note that trie cursor moves to the iiht one cell at a tim e.  

The Shift+Tab Keys  

• Hold down the Shift key and then press Tab. Note that the cursor moves to the left one cell 

at a time.  

The Right and Left Arrow Keys  

1. Press the right arrow key several times. Note that the cursor moves to the right.  

2. Press the left arrow key several times. Note that the cursor moves to the left. 
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Page Up and Page Down  

1. Press the Page Down key. Note that the cursor moves down one page.  

2. Press the Page Up key. Note that the cursor moves up one page.  

The CtrI-Home Key 

1.Move the cursor to column J.  

2. Stay in column J and move the cursor to row 20.  

3. Hold down the Ctrl key while you press the Home key. Excel moves to cell Al.  

Go To Cells Quickly  

The following are shortcuts for moving quickly from one cell in a worksheet to a cell in a 

different part of the worksheet.  

Goto--F5  

The F5 function key is the “Go To” key. If you press the F5 key, you are prompted for the 

cell to which you wish to go. Enter the cell address, and the cursor jumps to that cell.  

1. Press F5. The Go To dialog box opens.  

2. Type J3 in the Reference field.  

3. Press Enter. Excel moves to cell J3.  

Go to -- Ctrl+G  

You can also use Ctrl+G to go to a specific cell.  

1. Hold down the Ctrl key while you press “g” (Ctrl+g). The Go To dialog box opens.  

2. Type C4 in the Reference field.  

3. Press Enter. Excel moves to cell C4.  

 

The Name Box  

You can also use the Name box to go to a specific cell. Just type the cell you want to go to 

in the  

Name box and then press Enter.  

 
1. Type BlO in the Name box. 

2. 2. Press Enter. Excel moves to cell BlO.  

 

Wrap Text  

When you type text that is too long to fit in the cell, the text overlaps the next cell. If you do 

not want it to overlap the next cell, you can wrap the text.  
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1. Move to cell A2.  

2. Type Text too long to fit.  

3. Press Enter. 

 
4. Return to cellA2.   

5. Choose the Home tab.  

6. Click the Wrap Text button Excel wraps the text in the ce1l. 

 

Insert and Delete Columns and Rows  

You can insert and delete columns and rows. When you delete a column, you delete 
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everything in the column from the top of the worksheet to the bottom of the worksheet. 

When you delete a row, you delete the entire row from left to right. Inserting a column or 

row inserts a completely new column or row.  

 

Merge and Center  
Sometimes, particularly when you give a title to a section of your worksheet, you will want 

to center a piece of text over several columns or rows.  

 

Add Background Color  

To make a section of your worksheet stand out, you can add background color to a cell or 

group of cells.  

1. Select cells B2 to E3.  

2. Choose the Home tab.  

3. Click the down arrow next to the Fill Color button  

4. Click the color dark blue. Excel places a dark blue background in the cells you selected.  

 

Change the Font, Font Size, and Font Color  
A font is a set of characters represented in a single typeface. Each character within a font is 

created by using the same basic style. Excel provides many different fonts from which you 

can choose. The size of a font is measured in points. There are 72 points to an inch. The 

number of points assigned to a font is based on the distance from the top to the bottom of its 

longest character. You can change the Font, Font Size, and Font Color of the data you enter 

into Excel.  

 

 

Adjust Row/Column - height / Width  
Some of the entries in row / column are too long to fit. You can quickly adjust the width to 

fit the longest entry.  

1. Move your mouse pointer over the line that separates column B and C. The Width 

Indicator appears.  

2. Double-click. The Column adjusts to fit the longest entry. 

 

Hiding a row or column:  
1. Select the rows or columns you want to hide.  

2. On the Format menu, point to either Row or Column, and then click Hide.  

 

Un Hiding a row or column:  

1. Select the rows or columns you want to unhide.  

2. On the Format menu, point to either Row or Column, and then click UnHide.  

 

Aligning Data in cells:  

When you enter data in a worksheet, by default, Excel left aligns the text entries and right 
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aligns the numeric entries. To change the alignment of data in cells, you can use the 

alignment buttons in the formatting toolbar or the Format, Cells command or label prefix.  

 

Using Format, Cells command: Make cell active, by clicking in the cell or by using the 

arrow keys. Click on Format menu, Cells command, Format Cells dialog box appears. It is 

divided into different pages (also called tabs). Initially, the Number page is selected. The 

Number page is used to apply number formatting. The options for selecting the alignment of 

the cell data are available in the Alignment page. The default horizontal alignment for all 

cells is General. To change the alignment, select the corresponding radio button.  

 

What is cell references?  

The cell coordinates in a formula are known as cell reference A cell reference defines the 

location of each cell.  

There are three types of cell references:  

Relative referencing: Relative referencing implies that if you copy or move the formula to 

another cell, the cells referred to in the formula will change accordingly The reference is 

adjusted relative to the new location of the formula. Relative referencing is the default mode 

of referencing in a spreadsheet.  

Absolute referencing: Absolute referencing that the coordinates of a cell are not changed 

when a formula is copied from one cell to another. All the cell references are prefixed by 

the $ sign to indicate that they are absolute cell references  

The F4 key is used to toggle between the absolute and relative modes of referencing cells.  

Mixed referencing: Only one of the coordinates of a cell is fixed.  

 

Formulas  
Formulas establish relationships between two or more cells. You can use formulas for 

performing calculations involving addition, subtraction, multiplication and division. 

Formulas are also the key to performing complex scientific and statistical operations. 

Formulas are stored in cells like data. However, they display the result of the calculation in 

the cell rather than the data. Formulas in Excel always begin with an equal () sign.  

Built-in Functions. 

 

Definition: Functions are special purpose programs that accept data and return a value after 

performing calculations on the data.  

E.g =Average(D3:D1O)  

1. The cell range D3:D10 is the argument of the Average function. You can have more that 

one argument.  

The function begins wfth an equal () sign. The arguments are enclosed in brackets. The 

arguments are separated by commas. if any argument contains a text value that includes 

a space, enclose the value in quotes (“ “).  

The excel functions can be classified into following categories.  

1. Statistical. 

2. Math & Trigonometry. 
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3. Date and time. 

4. Logical. 

5. Text or String. 

 

The steps to insert a function:  
1. Select the cell where you want to insert the function.  

2. Select the Function option from the Insert menu.  

3. Select the function that you want to use.  

4. Click on the Next button.  

5. Type the argument in the text box.  

 

MATH & TRlGONOMETRY FUNCTIONS 

1. SUM:  

Adds all the numbers in a range of cells.  

Syntax : 

SUM(numberl,number2, ...)  

Numberl, number2, ... are 1 to 30 arguments for which you want the total value or sum. 

Numbers logical values and text representations of numbers that you type directly into the 

list of arguments are counted; See the first and second examples following.  

Exam pie:  

SUM(3, 2) equals 5  

SUM(”3”, 2, TRUE) equals 6 because the text values are translated into numbers, and the  

logical  value TRUE is translated into the number 1.  

 

Unlike the previous example, if Al contains „3‟ and Bi contains TRUE, then:  

SUM(A1, Bi, 2) equals 2 because references to non numeric values in references are not  

translated.  

If cells A2:E2 contain 5, 15, 30, 40, and 50:  

SUM(A2:C2) equals 50   

SUM(B2:E2, 15) equals 150 

  

2. ABS:  
Returns the absolute value of a number. The absolute value of a number is the number 

wfthout its sign. it converts the negative value into positive value.  

Syntax: 

ABS(number)  
Number is the real number of which you want the absolute value.  

Examples:  

ABS(2) equals 2  

ABS(-2) equals 2  

If Al contains -16, then:  

ABS(Al)equals 16.  
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3.INT:  
Rounds a number down to the nearest integer.  

Syntax:  

INT(number)  

Number is the real number you want to round down to an integer.  

Examples : 

INT(8.9) equals 8  

INT(-8.9) equals -9  

The following formula returns the decimal part of a positive real number in cell Al:  

INT(Al)  

 

4. MOD:  
Returns the remainder after number is divided by divisor. The result has the same sign as 

divisor. V  

Syntax  

MOD(number, divisor)  

Number is the number for which you Want to find the remainder.  

Divisor is the number by which you want to divide number. If divisor is 0, MOD returns the  

#DIV/0! error value.  

Examples  

MOD(3, 2) equals 1  

MOD(-3, 2) equals 1  

MOD(3, -2) equals -l  

MOD(-3, -2) equals -l  

 

5.ROUND 

Rounds a number to a specified number of digits.  

Syntax : 

ROUND(number,num digits)  
Number is the number you want to round.  

Num_digits specifies the number of digits to which you want to round number.  

• If nurn_digits is greater than 0 (zero), then number is rounded to the specified number of 

decimal places.  

• If num_digits is 0, then number is rounded to the nearest integer 

If num digits is less than 0, then number is rounded to the left of the decimal point.  

Examples 

ROUND(2.15, 1) equals 2.2  

ROUND(2.149, 1) equals 2.1  

RQUND(-1.475, 2) equals -1.48  

ROUND(21.5, -1) equals 20  
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6.SQRT:  

Returns a positive square root.  

Syntax : 

SQRT(number)  

Number is the number for which you want the square root. if number is negative, SQRT 

returns the #NUM! error value.  

Exam pies  

SQRT(16) equals 4  

SQRT(-16) equals #NUM!  

SQRT(ABS(-16)) equals 4  

7. TRUNC:  

Truncates a number to an integer by removing the fractional part of the number.  

Syntax  

TRUNC(number,num digits)  

Number is the number you want to truncate.  

Num_digits is a number specifying the precision of the truncation. The default value for 

num_digits is 0 (zero).  

Remarks: 

TRUNC and INT are similar in that both return integers. TRUNC removes the fractional 

part of the number. INT rounds numbers down to the nearest integer based on the value of 

the fractional part of the number. INT and TRUNC are different only when using negative 

numbers:  

TRUNC(-4.3) returns -4, but INT(-4.3) returns -5 because -5 is the lower number.  

Examples  

TRUNC(8.9) equals 8  

TRLJNC(-8.9) equals -8  

TRUNC(PIQ) equals 3  

8.FACT:  
Returns the factorial of a number. The factorial of a number is equal to 1*2*3*...* number.  

Syntax  

FACT(number)  

Number is the nonnegative number you want the factorial of. If number is not an integer, it 

is  

truncated.  

Examples  

FACT(1) equals I  

FACT(1 .9) equals FACT(1) equals 1  

FACT(O) equals 1  
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FACT(-1) equals #UM!  

FACT(5) equals 1*2*3*4*5 equals 120  

9. POWER:  

Returns the result of a number raised to a power.  

Syntax  

POWER(number,power)  

Number is the base number. It can be any real number.  

Power is the exponent to which the base number is raised.  

Remarks  

The “A” operator can be used instead of POWER to indicate to what power the base 

number is to be raised, such as in 5‟2.  

Examples  

POWER(5,2) equals 25  

POWER(98.6,3.2) equals 2401077  

10.PRODUCT:  

Multiplies all the numbers given as arguments and returns the product.  

Syntax  

PRODUCT(numberl ,number2, ...)  

Numberl, number2, ... are 1 to 30 numbers that you want to multiply.  

Remarks  

Arguments that are numbers, logical values, or text representations of numbers are counted; 

arguments that are error values or text that cannot be translated into numbers cause errors.  

Examples  

If cells A2:C2 contain 5, 15, and 30:  

PRODUCT(A2:C2) equals 2,250  

PRODUCT(A2:C2, 2) equals 4,500  

11.SUMIF:  

Adds the cells specified by a given criteria.  

Syntax  
SUMIF(range, criteria, sum range)  

Range is the range of cells you want evaluated 

Criteria are the criteria in the form of a number, expression, or text that defines which cells 

will  

be added. For example, criteria can be expressed as 32, „32”, “>32”, “apples”.  

Sum range are the actual cells to sum.  

Remarks  
• The cells in sum_range are summed only if their corresponding cells in range match the 

criteria.  

• If sum_range is omitted, the cells in range are summed.  
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• Microsoft Excel provides additional functions that can be used to analyze your data based 

on a condition. For example, to count the number of occurrences of a string of text or a 

number within a range of cells, use the COUNTIF function. To have a formula return one of 

two values based on a condition, such as a sales bonus based on a specified sales amount, 

use the IF function.  

 

STRlNG FUNCTIONS:  

1.Char:  

Returns the character specified by a number. Use CHAR to translate code page numbers 

you might get from files on other types of computers into characters.  

Syntax  

CHAR(n umber)  

Number is a number between 1 and 255 specifying which character you want. The character 

is from the character set used by your computer.  

Examples  

CHAR(65) equals “A”  

CHAR(33) equals “!” . 

 

2. Exact:  

Compares two text strings and returns TRUE if they are exactly the same, FALSE 

otherwise. EXACT is case-sensitive but ignores formatting differences. Use EXACT to test 

text being entered into a document.  

Syntax  

EXACT(textl ,text2)  

Text1 is the first text string.  

Text2 is the second text string.  

Examples . 

EXACT(”word”,”word”) equals TRUE  

EXACT(”Word”,”word”) equals FALSE  

EXACT(‟word‟‟word‟) equals FALSE  

 

3. Len:  

LEN returns the number of characters in a text string. 

Syntax: 

LEN(text)  

Text is the text whose length you want to find. Space is counted as characters.  

Examples  

LEN(”Phoenix, AZ”) equals 11  

LEN(”) equals 0  

 

4. Lower:  

Converts all uppercase letters in a text string to lowercase.  



Unit-2 BBA-ITM SEM-1 PCSP 
 

PREMAL SONI                                                                                                               Page 16 of 29 

Syntax : 

LOWER(text)  

Text is the text you want to convert to lowercase. LOWER does not change characters in 

text that are not letters.  

Examples  

LOWER(”E. E. Cummings”) equals “e. e. cummings”  

LOWER(”Apt. 2B”) equals “apt. 2b”  

 

5.Mid:  
MID returns a specific number of characters from a text string, starting at the position you 

specify, based on the number of characters you specify  

Syntax : 

MID(text,start_num , num_chars)  

Text is the text string containing the characters you want to extract.  

Start_num is the position of the first character you want to extract in text. The first character 

ii text has start num 1, and so on:  

• If start_num is greater than the length of text, MID returns “„ (empty text).  

• If start num is less than the length of text, but start num plus num_chars exceeds the length 

of text,  MID returns the characters up to the end of text.  

• If start num is less than 1, MID returns the #VALUE! error value.  

Num_chars specifies the number of characters you want MID to return from text. If 

num_chars is negative, MID returns the #VALUE! error value.  

Examples  

MID(”Fluid Fiow”,1,5) equals “Fluid‟  

MID(”Fluid Flow”,7,20) equals “Flow‟T  

MID(”abcd”,5,5) equals “ (empty text)  

 

6. Upper:  

Converts text to uppercase.  

Syntax  
UPPER(text)  

Text is the text you want converted to uppercase. Text can be a reference or text string.  

Examples  

UPPER(”total”) equals “TOTAL”  

If E5 contains “yield”, then:  

UPPER(E5) equals “YIELD”  

my-it. CODE:  

Returns a numeric code for the first character in a text string. The returned code corresponds 

to the character set used by your computer.  

Syntax  

CODE(text)  
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Text is the text for which you want the code of the first character.  

Example  

CODE(”A”) Displays the numeric code for A (65)  

=CODE(”!”) Displays the numeric code for! (33)  

 

7. SUBSTITUTE:  
Substitutes new_text for old_text in a text string. Use SUBSTITUTE when you want to 

replace specific text in a text string; use REPLACE when you want to replace any text that 

occurs in a specific location in a text string.  

Syntax  
SUBSTITUTE(text old_text new text instance num)  

Text is the text or the reference to a cell containing text for which you want to substitute 

characters.  

Old_text is the text you want to replace.  

New_text is the text you want to replace old_text with.  

Instance nurn specifies which occurrence of old text you want to replace with new_text. If 

you specify instance nurn, only that instance of old_text is replaced. Otherwise, every 

occurrence of old_text in text is changed to new_text.  

Example  

          A  

         Data  

Sales Data  

Quarter 1,2008  

Quarterl,2011  

Formula Description (Result)  

=SUBSTITUTE(A2, “Sales”, “Cost”) Substitutes Cost for Sales (Cost Data)  

=SUBST1TUTE(A3 “1” “2” 1) Substitutes first instance of “1” with “2” (Quarter 2,  

=SUBSTITUTE(A4, , “2”, 3) Substitutes third instance of “1” with “2” (Quarter 1,2012) 

 

8. CONCATENATE:  
Joins several text strings into one text string.  

Syntax  

CONCATENATE (texti ,text2,...)  

Texti, text2, .. are 1 to 30 text items to be joined into a single text item. The text items óan 

be text strings, numbers, or single-cell references.  

Remarks  

The “&”operator can be used instead of CONCATENATE to join text items.  

Example  

                     A  

                    Data  

brook trout  
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Species  

32  

Formula Description(Result)  

Concatenates a sentence from the data above  

=CONCATENATE( Stream population  

for “,A2,” “,A3 „is “,A4,”/mile”) (Stream population for brook trout species is  

32/mile)  

 

9.TRlM:  
Removes afl spaces horn text except for single spaces between woids. Use TRIM on text 

that  

you have received from another application that may have irregular spacing.  

Syntax  

TRIM(text)  

Text is the text from which you want spaces removed.  

Example  

=TRIM(” First Quarter Earnings) 

Removes leading and trailing spaces from the text in the formula Earnings .(First Quarter 

Earnings) 

 

10. REPT:  

Repeats text a given number of times  

Syntax  

REPT(text,number_times)  

Example  

=rept(”PC”,20)  

 

STASTATICAL FUNCTIONS  

These functions perform statistical calculations on list of values.  

 

1.AVERAGE 

It returns the average (arithmetic mean) of the arguments. 

Syntax: 

AVERAGE (numberl, number2 )  

Numberl, number2, ... are 1 to 30 numeric arguments for which you want the average.  

Example:  

If A1:A5 is named(Range) Scores and contains the numbers 10, 7,9,27, and 2, then:  

AVERAGE(A1:A5) equals 11  

AVERAGE(Scores) equals 11  

AVERAGE(A1:A5, 5) equals 10  
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AVERAGE(A1 :A5) equals SUM(A1 :A5)/COUNT(A1 :A5) equals 11  

If Cl C3 is named OtherScores and contains the numbers 4 18 and 7 then  

AVERAGE(Scores, OtherScores) equals 10.5.  

 

2.COUNT 
Counts the number of cells that contain numbers and numbers within the list of arguments. 

Use COUNT to get the number of entries in a number field in a range or array of numbers.  

Syntax  
COUNT(valuel,value2, ...)  

Arguments that are numbers, dates, or text representations of numbers are counted: 

arguments that are error values or text that cannot be translated into numbers are ignored.  

Example: 
In the following example,  

 

 A 

1 Sales 

2 12/12/01 

3 19 

4 22.4 

5  

6 TRUE 

7 #DEV 

COUNT(A1:A7) equals 3  

COUNT(A4:A7) equals 1  

COUNT(Ai:A7, 2) equals 4  

3.MAX:  

Returns the largest value in a set of values.  

Syntax  
MAX(numberl ,number2,...)  

Numberl,Number2,... are numbers for which you want to find the maximum value.  

Example:  
If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then:  

MAX(A I :A5) equals 27  

MAX(A1:A5,30) equals 30.  

4. MIN:  

Returns the smallest number in a set of values.  

Syntax  

MIN(numberl,number2, ...)  

Number1, number2,... are 1 to 30 numbers for which you want to find the minimum value. 

Note for MAX & MIN Functions:  
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You can specify arguments that are numbers, empty cells, logical values, or text 

representations of numbers. Arguments that are error values or text that cannot be translated 

into numbers cause errors.  

Example:  

If A1:A5 contains the numbers 10.7.9.27. and 2, then:  

MIN(A1:A5) equals 2  

MIN(A1:A5, 0)equals 0  

5.COUNTA:  

Counts the number of cells that are not empty within the list of arguments. Use COUNTA to 

get the number of non-empty cells in a range.  

Syntax  

COUNTA(valuel,value2, ...)  

Arguments that are not numbers, dates, error values or text representations of numbers are 

counted.  

 A 

1 Sales 

2 12/12/01 

3 19 

4 22.4 

5  

6 TRUE 

7 #DEV 

 

Examples  

In the following example,  

 COUNT(A1:A7) equals 6  

COUNT(A4:A7) equals 3  

 

LOGICAL FUNCTIONS  

1.IF 

Returns one value if a condition you specify evaluates to TRUE and another value if it 

evaluates to FALSE.  

Use IF to conduct conditional tests on values and formulas.  

Syntax  

IF(Iogical_test,value_if_true ,value_if_false)  

Logical_test is any value or expression that can be evaluated to TRUE or FALSE. For 

example, Al 0=100 is a logical expression; if the value in cell Al0 is equal to 100, the 

expression evaluates to TRUE. Otherwise, the expression evaluates to FALSE. 
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Value_if_true  is the value that is returned if logical_test is TRUE. For example, if this 

argument is the text string “Within budget” and the logical test argument evaluates to TRUE 

then the IF function displays the text “Within budget” If logical test is TRUE and 

value_if_true is blank this argument returns 0 (zero) To display the word TRUE use the 

logical value TRUE for this argument. Value_if_true can be another formula.  

 

Value_if_false is the value that is returned if logical_test is FALSE. For example, if this 

argument is the text string „Over budget” and the logical_test argument evaluates to FALSE 

then the IF function displays the text “Over budget” If logical_test is FALSE and 

value_if_false is omitted (that is, after value_if_true there is no comma) then the logical 

value FALSE is returned If logical_test is FALSE and value_if_false is blank (that is after 

value_if_true there is a comma followed by the closing parenthesis), then the value 0 (zero) 

is returned. Value_if_false can be another formula.  

 

Remarks  

 • Up to seven, IF functions can be nested as value_if_true and value_if_false arguments to 

construct more elaborate tests. See the following last example. 

 • When the value_if_true and value_if_false arguments are evaluated, IF returns the value  

returned by those statements.  

• If any of the arguments to IF are arrays, every element of the array is evaluated when the 

IF statement is carried out.  

 

On a budget sheet, cell AlO contains a formula to calculate the current budget. If the result 

of the formula in AlO is less than or equal to 100, then the following function displays 

“Within budget”. Otherwise, the function displays “Over budget”. 

  

If(A1 0< 1 00,”Within budget”, “Over budget”)  

 

In the following example, if the value in cell AlO is 100, then logical_test is TRUE, and the 

total value for the range B5:B15 is calculated. Otherwise, logical_test is FALSE, and empty 

text (“) is returned that blanks the cell that contains the IF function. 

  

IF(A1 0=1 00,SUM(B5:B1 5),”)  

 

Suppose an expense worksheet contains in B2:B4 the following data for “Actual Expenses” 

for January, February, and March: 1500, 500, 500. C2:C4 contains the following data for 

“Predicted Expenses” for the same periods: 900, 900, 925.  

You can write a formula to check whether you are over budget for a particular month, 

generating text for a message with the following formulas:  

 

IF(B2>C2 “Over Budget”,”OK”) equals “Over Budget”  
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IF(B3>C3,”Over Budget”,”OK”) equals “OK”  

 

Suppose you want to assign letter grades to numbers referenced by the name  

AverageScore. See the following table.  

 

If AverageScore is       Then return  

Greater than 89   A  

From 80 to 89    B  

From 70 to 79     C  

From 60 to 69     D  

Less than 60     F  

 

You can use the following nested IF function:  

 

IF(AverageScore>89,”A”,lF(AverageScore>79,”B”,IF(AverageSCore>69 ,“C”, 

  

IF(AverageScorè>59,”D”,”F”))))  

 

In the above example, the second IF statement is also the value_if_false argument to the 

first IF statement. Similarly, the third IF statement is the value_if_false argument to the 

second IF statement. For example, if the first logical_test (Average>89) is TRUE, “A” is 

returned. If the tirst logical_test is FALSE, the second IF statement is evaluated, and so on.  

 

 

2.AND : 

Returns TRUE if all its arguments are TRUE; returns FALSE if one or more arguments is 

FALSE.  

 

Syntax  

OR(Iogical1,logical2,...)  

Log ical Iogical2 are 1 to 30 conditions you want to test that can be either TRUE or FALSE  

• The arguments must evaluate to logical values such as TRUE or FALSE or in arrays or 

references that contain logical values.  

• If an array or reference argument contains text or empty cells those values are ignored  

• If the specified range contains no logical values, OR returns the #VALUEI error value.  

Examples  

OR(TRUE) equals TRUE  

OR(1+1=1,2+2=5) equals FALSE  

If Al :A3 contains the values TRUE, FALSE, and TRUE, then:  

OR(A1:A3) equals TRUE  

NOT  

Reverses the value of its argument. Use NOT when you want to make sure a value is not 
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equal to one particular value.  

Syntax  

NOT(logical*)  

Logical is a value or expression that can be evaluated to TRUE or FALSE. If logical is 

FALSE, NOT returns TRUE; if logical is TRUE. NOT returns FALSE 

Examples  

NOT(FALSE) equals TRUE  

NOT(1÷1=2) equals FALSE  

 

WHAT IS DBMS?  

In earlier data management system, each system is developed separately and each one 

operates independently. Thus a data file created by X program cannot be accessed by Y 

program unless it understand the file structured specified in program X. Due to this there 

was a high software development cost, less data integrity and inability to get quick answer.  

To overcome these drawbacks, a system was developed in early 1980‟s known as DBMS-- 

Data Base Management System. The whole system was based on Database.  

The software packages designed to build and manage the database, i.e. add, edit, delete, sort 

information in the database, so that the database is to up-to-date and helps to retrieve (gçt 

back) the desired information in the required format from the database. The software in 

effect automatically manages the storage and processing of data comprising the database. 

  

What is Database?  
Database is an organized collection of related information (data). E.g. Student database. 

Another example of Database is telephone directory where in first column you will find 

holders name and in the next column you will find corresponding phone no. Thus any value 

appearing under first column always display Holder‟s name.  

 

What is database file?  
When the information is stored in a computer file using a database management system 

such as FoxPro, the file is called a database file One database file will have only one kind of 

information e.g. is an student database file, you will store only details regarding students 

and nothing else. A database file is consisting of records and Fields.  

Record  
Each physical line of a database is called Record or A record is a representation of some 

physical or conceptual object having multiple attributes or is all the information about a 

single item in your file.  

Field  

A Field is one of the units of information within each record or each column of a line is 

called a field.  

 

SORTING  

Excel provides a very powerful command to sort the database, i.e. arrange the information 

stored in it in a desired order. To sort a database on a single field, use the Sort buttons on 
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the standard toolbar or the Data, Sort command. Excel can sort on up to three fields. While 

sorting a database on two fields, Excel first sorts the database on the first field (also called 

as primary key) and then sorts all records with the same primary key value on the second 

field.  

You can sort data by text (A to Z or Z to A), numbers (smallest to largest or largest to 

smallest) i.e. Ascending or Descending order.  

 

SUBTOTAL  
It automatically calculates subtotals and grand totals in a list (list: A series of rows that 

contains related data) for a column by using the Subtotal command in the Outline group on 

the Data tab.  

Grand totals are derived from detail data (detail data: For automatic subtotals and worksheet 

outlines, the subtotal rows or columns that are totaled by summary data. Detail data is 

typically adjacent to and either above or to the left of the summary data,not from the values 

in the subtotals. For example, if you use the Average summary function, the grand total row 

displays an average of all detail rows in the list, not an average of the values in the subtotal 

rows.  

 

1. Sort the column that forms the group.  

2 On the Data tab in the Outline group click Subtotal, the Subtotal dialog box is displayed.  

3. In the At each change in box, click the column to subtotal. In the example above, you 

would select Sport.  

4. In the Use function box, click the summary function that you want to use to calculate the 

subtotals. In the example above, you would select Sum.  

5 In the Add subtotal to box select the check box for each column that contains values that 

you want to subtotal. In the example above, you would select Sales.  

6. To specify a summary row above the details row, clear the Summary below data check 

box. To specify a summary row below the details row, sect the Summary below data check 

box. In the example above, you would clear the check box. 

 

AUTO FILTER  
The Auto filter enables you to specify criteria and then Excel temporarily hides those rows 

in the database that do not meet the criteria. Use the Data, Filter command. That contains 

three commands- Auto filter, Show all and Advanced filter. Click Auto filter and Excel 

displays dropdown arrows on the right side of all fieldnames in the header row. It contains 

the following automatic filter options 

 

Note - The Blanks and Non Blanks options are available only if the column you want to 

filter contains a blank cell.  

 

For auto Filter follow the following steps:  

1. Select a range of cells containing alphanumeric data.  

2. On the Home tab, in the Editing group, click Sort & Filter, and then click Filter.  
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3 Click the arrow in the column header  

4. Click Select from a list of text values  

• In the list of text values, select or clear one or more text values to filter by The list of text 

values can be up to 10,000. If the list is large, clear (Select All) at the top, and then select 

the specific text values to filter by.  

• Point to Text Filters and then click one of-the comparison operator commands, or click 

Custom Filter For example to filter by text that begins with a specific character select 

Begins With, or to filter by text that has specific characters anywhere in the text, select 

Contains.  
• In the Custom AutoFilter dialog box in the box on the right enter text or select the text 

value from the list For example to filter by text that begins with the letter „J‟ enter J, or to 

filter by text that has “bell” anywhere in the text enter bell If you need to find text that 

shares some characters but not others use a wildcard character  

5. Optionally, filter by one more criteria.  

 

ADVACNCED FILTER  
The advanced filter command in the Data, Filter submenu enables you to specify relatively 

complex criteria. It also enables you to copy the records that meet the specified criteria to 

another location in the worksheet. While using Advanced filter, we use a separate area of 

the worksheet to specify the condition or criteria. The range where we enter the criteria is 

called the criteria range. To find the records that meet specified criteria, it requires the 

following steps:  

1. Click a cell in the range.  

2. On the Data tab, in the Sort & Filter group, click Advanced 

 

To filter the range by hiding rows that don‟t match your criteria, click Filter the list, in- 

place.  

To filter the range by copying rows that match your criteria to another area of the 

worksheet, click Copy to another location, click in the Copy to box, and then click the 

upper-left corner of the area where you want to paste the rows.  

4. In the Criteria range box, enter the reference for the criteria range, including the criteria 

labels.  

To move the Advanced Filter dialog box out of the way temporarily while you select the  

criteria range, click Collapse Dialog I4  
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5. To change how the data is filtered, change the values in the criteria range and filter the 

data again.  

CHART (GRAPH-PLOTTING) FACILITIES  

Charts present data visually, more effectively and help to analyze data. Charts can present 

volumes of data in a concise easy to understand format. Charts can retrieved data from more 

than one workbook and thus is one  of the most effective data consolidation tools provided 

by Excel. Generating charts help in decision making and forecasting.  

Types of charts in Excel: Area, Column, Bar, Line, Pie, Doughnut, Stock, XY (scatter), 

Bubble, Radar, Surface, Cone, Cylinder and Pyramid charts.  

A chart consists of the following components:  

1. Data: A chart represents the relationship between two sets of data. Thus, in order to create 

a  

chart, you need at least two sets of data. One set of data is represented on the X-axis of the  

chart and the other on the Y-ads.  

2. Axis Label: You need to assign labels to the sets of data in order to convey their purpose.  

3. Legend: A legend identifies a set of data. If you are representing more than one set of 

data on  

the same axis, you need to create legends for the data sets.  

4. Data labels: Data labels are required to display the numerical value of a bar or section in a 

chart.  

 In Microsoft excel, you can represent numbers in a chart.  

 On the Insert tab, you can choose from a variety of chart types, including column, 

line, pie, bar, area, and scatter. 

  The basic procedure for creating a chart is the same no matter what type of chart you 

choose.  

 As you change your data, your chart will automatically update.  

 You select a chart type by choosing an option from the Insert tab‟s Chart group. 

 After you choose a chart type, such as column, line, or bar, you choose a chart sub-

type. 

 

 

 

Create a Chart  
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1. Select cells A3 to D6. You must select all the cells containing the data you want in 

your chart. You should also include the data labels.  

2. Choose the Insert tab.  

3. Click the Column button in the Charts group. A list of column chart sub-types types 

appears.  

4. Click the Clustered Column chart sub-type. Excel creates a Clustered Column chart 

and the Chart Tools context tabs appear.  

Apply a Chart Layout  

 

1. Click your chart. The Chart Tools become available.  

2. Choose the Design tab.  

3. Click the Quick Layout button in the Chart Layout group. A list of chart layouts appears. 

4. Click Layout 5. Excel applies the layout to your chart.  

Add Labels  

When you apply a layout, Excel may create areas where you can insert labels. You use 

labels to give your chart a title or to label your axes. When you applied layout 5, Excel 

created label areas for a title and for the vertical axis.  

1. Select Chart Title. Click on Chart Title and then place your cursor before the C in Chart 

and hold down the Shift key while you use the right arrow key to highlight the words Chart 

Title.  

2. Type Toy Sales. Excel adds your title.  

3. Select Axis Title. Click on Axis Title. Place your cursor before the A in Axis. Hold down 

the Shift key while you use the right arrow key to highlight the words Axis Title.  

4. Type Sales. Excel labels the axis.  

5. Click anywhere on the chart to end your entry.  

Switch Data  

If you want to change what displays in your chart, you can switch from and vice versa.  

1. Click your chart. The Chart Tools become available.  

2. Choose the Design tab.  

3. Click the Switch Row/Column button in the Data group. Excel changes the data in your 

chart. 

Change the Style of a Chart  

A style is a set of formatting options. You can use a style to change the color and format of 

your chart. Excel 2007 has several predefined styles that you can use. They are numbered 

from left to right, starting with 1, which is located in the upper-left corner.  

1. Click your chart. The Chart Tools become available.  

2. Choose the Design tab.  
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3. Click the More button in the Chart Styles group. The chart styles appear. -.  

4. Click Style 42. Excel applies the style to your chart.  
 

Change the Size and Position of a Chart  

When you click a chart, handles appear on the right and left sides, the top and bottom, and 

the corners of the chart. You can drag the handles on the top and bottom of the chart to 

increase or decrease the height of the chart. You can drag the handles on the left and right 

sides to increase or decrease the width of the chart. You can drag the handles on the corners 

to increase or decrease the size of the chart proportion ally. You can change the position of a 

chart by clicking on an unused area of the chart and dragging.  

1. Use the handles to adjust the size of your chart.  

2. Click an unused portion of the chart and drag to position the chart beside the data.  

 

Move a Chart to a Chart Sheet  

By default, when you create a chart, Excel embeds the chart in the active worksheet. 

However, you can move a chart to another worksheet or to a chart sheet. A chart sheet is a 

sheet dedicated to a particular chart. By default Excel names each chart sheet sequentially, 

starting with Chart. You can change the name. 

1. Click your chart. The Chart Tools become available.  

2. Choose the Design tab.  

3. Click the Move Chart button in the Location group. The Move Chart dialog box appears 

4. Click the New Sheet radio button.  

5. Type Toy Sales to name the chart sheet. Excel creates a chart sheet named Toy Sales and 

places your chart on it.  

 

Change the Chart Type  
Any change you can make to a chart that is embedded in a worksheet, you can also make to 

a chart sheet. For example, you can change the chart typo from a column chart to a chart.  

 

1. Click your chart. The Chart Tools become available.  

2. Choose the Design tab.  

3. Click Change Chart Type in the Type group. The Chart Type dialog box appears. 

4. Click Bar. 

5. Click Clustered Horizontal Cylinder.  

6. Click OK. Excel changes your chart type.  
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Steps to create a chart automatically:  

1. Select the data range on which the chart will be based.  

2. Press the Fl1 key.  

Excel creates a chart in a separate chart sheet.  

Pie Chart:  

A pie chart presents the various data value of a range as wedge-shaped sections (pies) of a 

circle. It displays the percentage of each part (data value) of the total of all values in the 

range. The total or the circle represents 100 percent This chart is suitable to display the 

budget allocation to different departments, to compare the profit for the different divisions 

of a company, or to compare the market shares of various P manufacturing companies in the 

total PC market. Since a pie chart can display only one range of values, it used the first data 

range and discards additional data range, if any.  

 

Disclaimer: The study material is compiled by Mr. Premal Soni. The basic objective of this 

material is to supplement teaching and discussion in the classroom in the subject. Students 

are required to go for extra reading in the subject through Library books recommended by 

Sardar Patel University, Vallabh Vidyanagar. Students should also consult the subject 

teacher for the solution of their problems in order to enhance their subject knowledge. 

 


